Sejarah MikroTik RouterOS



Sejarah MikroTik RouterOS


MikroTik adalah sebuah perusahaan kecil berkantor pusat di Latvia, bersebelahan dengan Rusia. Pembentukannya diprakarsai oleh John Trully dan Arnis Riekstins. John Trully adalah seorang berkewarganegaraan Amerika yang berimigrasi ke Latvia. Di Latvia ia bejumpa dengan Arnis, Seorang darjana Fisika dan Mekanik sekitar tahun 1995.

John dan Arnis mulai me-routing dunia pada tahun 1996 (misi MikroTik adalah me- routing seluruh dunia). Mulai dengan sistem Linux dan MS-DOS yang dikombinasikan dengan teknologi Wireless-LAN (WLAN) Aeronet berkecepatan 2 Mbps di Moldova, negara tetangga Latvia, baru kemudian melayani lima pelanggannya di Latvia.

Prinsip dasar mereka bukan membuat Wireless ISP (W-ISP), tetapi membuat program router yang handal dan dapat dijalankan diseluruh dunia. Latvia hanya merupakan tempat eksperimen John dan Arnis, karena saat ini mereka sudah membantu negara-negara lain termasuk Srilanka yang melayani sekitar 400 pengguna.

Linux yang pertama kali digunakan adalah Kernel 2.2 yang dikembangkan secara bersama-sama denag bantuan 5-15 orang staff Research and Development (R&D) MikroTik yang sekarang menguasai dunia routing di negara-negara berkembang. Menurut Arnis, selain staf di lingkungan MikroTik, mereka juga merekrut tenega-tenaga lepas dan pihak ketiga yang dengan intensif mengembangkan MikroTik secara marathon.





Jenis-Jenis Mikrotik



1. MikroTik RouterOS yang berbentuk software yang dapat di-download di www.mikrotik.com. Dapat diinstal pada kompuetr rumahan (PC).

2. MikroTik RouterBoard yaitu BUILT-IN Hardware Mikrotik dalam bentuk perangkat keras yang khusus dikemas dalam board router yang didalamnya sudah terinstal MikroTik RouterOS.





Fitur-Fitur Mikrotik
Address List : Pengelompokan IP Address berdasarkan nama
Asynchronous : Mendukung serial PPP dial-in / dial-out, dengan otentikasi CHAP, PAP, MSCHAPv1 dan MSCHAPv2, Radius, dial on demand, modem pool hingga 128 ports.
Bonding : Mendukung dalam pengkombinasian beberapa antarmuka ethernet ke dalam 1 pipa pada koneksi cepat.
Bridge : Mendukung fungsi bridge spinning tree, multiple bridge interface, bridging firewalling.
Data Rate Management : QoS berbasis HTB dengan penggunaan burst, PCQ, RED, SFQ, FIFO queue, CIR, MIR, limit antar peer to peer
DHCP : Mendukung DHCP tiap antarmuka; DHCP Relay; DHCP Client, multiple network DHCP; static and dynamic DHCP leases.
Firewall dan NAT : Mendukung pemfilteran koneksi peer to peer, source NAT dan destination NAT. Mampu memfilter berdasarkan MAC, IP address, range port, protokol IP, pemilihan opsi protokol seperti ICMP, TCP Flags dan MSS.
Hotspot : Hotspot gateway dengan otentikasi RADIUS. Mendukung limit data rate, SSL ,HTTPS.
IPSec : Protokol AH dan ESP untuk IPSec; MODP Diffie-Hellmann groups 1, 2, 5; MD5 dan algoritma SHA1 hashing; algoritma enkirpsi menggunakan DES, 3DES, AES-128, AES-192, AES-256; Perfect Forwarding Secresy (PFS) MODP groups 1, 2,5
ISDN : mendukung ISDN dial-in/dial-out. Dengan otentikasi PAP, CHAP, MSCHAPv1 dan MSCHAPv2, Radius. Mendukung 128K bundle, Cisco HDLC, x751, x75ui, x75bui line protokol.
M3P : MikroTik Protokol Paket Packer untuk wireless links dan ethernet.
MNDP : MikroTik Discovery Neighbour Protokol, juga mendukung Cisco Discovery Protokol (CDP).
Monitoring / Accounting : Laporan Traffic IP, log, statistik graph yang dapat diakses melalui HTTP.
NTP : Network Time Protokol untuk server dan clients; sinkronisasi menggunakan system GPS.
Poin to Point Tunneling Protocol : PPTP, PPPoE dan L2TP Access Consentrator; protokol otentikasi menggunakan PAP, CHAP, MSCHAPv1, MSCHAPv2; otentikasi dan laporan Radius; enkripsi MPPE; kompresi untuk PPoE; limit data rate.
Proxy : Cache untuk FTP dan HTTP proxy server, HTTPS proxy; transparent proxy untuk DNS dan HTTP; mendukung protokol SOCKS; mendukung parent proxy; static DNS.
Routing : Routing statik dan dinamik; RIP v1/v2, OSPF v2, BGP v4.
SDSL : Mendukung Single Line DSL; mode pemutusan jalur koneksi dan jaringan.
Simple Tunnel : Tunnel IPIP dan EoIP (Ethernet over IP).
SNMP : Simple Network Monitoring Protocol mode akses read-only.
Synchronous : V.35, V.24, E1/T1, X21, DS3 (T3) media ttypes; sync-PPP, Cisco HDLC; Frame Relay line protokol; ANSI-617d (ANDI atau annex D) dan Q933a (CCITT atau annex A); Frame Relay jenis LMI.
Tool : Ping, Traceroute; bandwidth test; ping flood; telnet; SSH; packet sniffer; Dinamik DNS update.
UPnP : Mendukung antarmuka Universal Plug and Play.
VLAN : Mendukung Virtual LAN IEEE 802.1q untuk jaringan ethernet dan wireless; multiple VLAN; VLAN bridging.
VoIP : Mendukung aplikasi voice over IP.
VRRP : Mendukung Virtual Router Redudant Protocol.
WinBox : Aplikasi mode GUI untuk meremote dan mengkonfigurasi MikroTik RouterOS.








Komponen Dasar Jaringan Komputer dan Pengertiannya - Sebelum kita lanjut belajar Mikrotik, ada baiknya belajar dulu tentang dasar dari Jaringan Komputer itu sendiri yang nantinya ilmu ini akan digunakan juga pada pemasangan dan penggunaan Mikrotik. Jaringan komputer adalahsekelompok komputer otonom yang saling dihubungkan satu sama lainnya, menggunakan suatu media dan protocol komunikasi tertentu, sehingga dapat saling berbagi data dan informasi. Jaringan komputer memungkinkan terjadinya komunikasi yang lebih efisien antar pemakai (mail dan teleconference).










Pengertian Jaringan Komputer


Jaringan komputer merupakan sekelompok komputer otonom yang saling menggunakan protokol komunikasi melalui media komunikasi sehingga dapat berbagi data, informasi, program aplikasi dan perangkat keras seperti printer, scanner, CD-Drive maupun harddisk serta memungkinkan komunikasi secara elektronik.

Sedangkan pada Aplikasi home user, memungkinkan komunikasi antar pengguna lebih efisien (chat), interaktif entertainment lebih multimedia (games, video,dan lain-lain).


Router adalah perangkat yang akan melewatkan paket IP dari suatu jaringan ke jaringan yang lain, menggunakan metode addressing dan protocol tertentu untuk melewatkan paket data tersebut.





Pengertian Router


Router adalah suatu alat yang memiliki kemampuan melewatkan paket IP dari satu jaringan ke jaringan lain yang mungkin memiliki banyak jalur diantara keduanya. Router-router yang saling terhubung dalam jaringan internet turut serta dalam sebuah algoritma routing terdistribusi untuk menentukan jalur terbaik yang dilalui paket IP dari system ke system lain. Proses routing dilakukan secara hop by hop. IP tidak mengetahui jalur keseluruhan menuju tujuan setiap paket. IP routing hanya menyediakan IP address dari router berikutnya yang menurutnya lebih dekat ke host tujuan.

Fungsi Router:
Membaca alamat logika / ip address source & destination untuk menentukan routing dari suatu LAN ke LAN lainnya.
Menyimpan routing table untuk menentukan rute terbaik antara LAN ke WAN.
Perangkat di layer 3 OSI Layer.
Bisa berupa “box” atau sebuah OS yang menjalankan sebuah daemon routing.
Interfaces Ethernet, Serial, ISDN BRI.







Pengertian Sistem Operasi


Sistem operasi adalah sekumpulan rutin perangkat lunak yang berada diantara program aplikasi dan perangkat keras (Bambang Hariyanto,2006,hal 25). Sistem operasi memiliki tugas yaitu mengelola seluruh sumber daya sistem komputer dan sebagai penyedia layanan.

Sistem operasi menyediakan System Call (berupa fungsi-fungsi atau API=Application Programming Interface). System Call ini memberikan abstraksi tingkat tinggi mesin untuk pemrograman. System Call berfungsi menghindarkan kompleksitas pemrograman dengan memberi sekumpulan instruksi yang lebih mudah dan nyaman, sistem operasi juga sebagai basis untuk program lain dimana program aplikasi dijalankan diatas sistem operasi, program-program itu memanfaatkan sumber daya sistem komputer dengan cara meminta layanan sistem operasi mengendalikan sumber daya untuk aplikasi sehingga penggunaan sumber daya sistem komputer dapat dilakukan secara benar dan efisien.

Sistem operasi yang dikenal antara lain :
Windows (95, 98, ME, 2000, XP, VISTA, SERVER, Windows7)
Linux (Red Hat, Slackware, Ubuntu, Fedora, Mikrotik, Debian, OpenSUSE)
UNIX
FreeBSD (Berkeley Software Distribution)
SUN (SOLARIS)
DOS (MS-DOS)
Machintosh (MAC OS, MAC OSX)







Klasifikasi Jaringan Komputer :



LAN (Local Area Network) adalah Jaringan komputer yang saling terhubung ke suatu komputer server dengan menggunakan topologi tertentu, biasanya digunakan dalam
kawasan satu gedung atau kawasan yang jaraknya tidak lebih dari 1 km.

MAN (Metropolitan Area Network) adalah Jaringan komputer yang saling terkoneksi dalam satu kawasan kota yang jaraknya bisa lebih dari 1 km. Pilihan untuk membangun jaringan komputer antar kantor dalam suatu kota, kampus dalam satu kota.


WAN (Wide Area Network) adalah Jaringan komputer yang menghubungkan banyak LAN ke dalam suatu jaringan terpadu, antara satu jaringan dengan jaringan lain dapat berjarak ribuan kilometer atau terpisahkan letak geografi dengan menggunakan metode komunikasi tertentu.

Secara garis besar ada beberapa tahapan dalam membangun jaringan LAN, diantaranya ;
Menentukan teknologi tipe jaringannya (Ethernet, Fast Ethernet, Token Ring, FDDI)
Memilih model perkabelan (Fiber, UTP, Coaxial)
Menentukan bentuk topologi jaringan (Bus, Ring, dan Star)
Menentukan teknologi Client/Server atau Peer to Peer
Memilih Sistem Operasi Server (Windows NT, 2000, XP, atau Linux)







Pengertian Gateway



Gateway adalah pintu gerbang sebagai keluar-masuknya paket data dari local network menuju outer network. Tujuannya agar client pada local network dapat berkomunikasi dengan internet. Router dapat disetting menjadi Gateway dimana ia menjadi penghubung antara jaringan local dengan jaringan luar.





Pengertian Proxy Server



Proxy Server adalah sebuah fasilitas untuk menghubungkan diri ke internet secara bersama-sama. Memenuhi permintaan user untuk layanan Internet (http, FTP,Telnet) dan mengirimkannya sesuai dengan kebijakan. Bertindak sebagai gateway menuju layanan. Mewakili paket data dari dalam dan dari luar. Menangani semua komunikasi internet – ekternal. Bertindak sebagai gateway antara mesin internal dan eksternal. Proxy server mengevaluasi dan mengontrol permintaan dari client, jika sesuai policy dilewatkan jika tidak di deny/drop. Menggunakan metode NAT. Memeriksa isi paket.





Pengertian Firewall



Firewall adalah sistem keamanan yang menggunakan device atau sistem yang diletakkan di dua jaringan dengan fungsi utama melakukan filtering terhadap akses yang akan masuk. Berupa seperangkat hardware atau software, bisa juga berupa seperangkat aturan dan prosedur yang ditetapkan oleh organisasi. Firewal juga dapat disebut sebagai sistem atau perangkat yang mengizinkan lalu lintas jaringan yang dianggapnya aman untuk melaluinya dan mencegah lalu lintas jaringan yang tidak aman. Umumnya firewall diimplementasikan dalam sebuah mesin terdedikasi, yang berjalan pada pintu gerbang (gateway) antara jaringan local dan jaringan lainnya. Firewall juga umumnya digunakan untuk mengontrol akses terhadap siapa saja yang memiliki akses terhadap jaringan pribadi dari hak luar. Saat ini, istilah firewall menjadi istilah generic yang merujuk pada sistem yang mengatur komunikasi antar dua jaringan yang berbeda.





Pengertian Virtual LAN



Virtual LAN (VLAN) adalah berupa suatu software dari device switch yang berfungsi untuk mengelompokan user berdasarkan fungsional, 1 broacast domain (1 VLAN) dan antar VLAN dapat terkoneksi dengan router.

Teknologi VLAN adalah suatu cara yang memisahkan segmen-segmen pada switch dimana antara 1 segmen dengan segmen lain tidak dapat terkoneksi, koneksi dapat dilakukan dengan menggunakan router. Dalam satu switch akan berbeda network-id-nya dan berbeda broadcast domainnya.









Mengkonfigurasi MikroTik menggunakan Command Line Interface (CLI) ini bisa kita lakukan dengan menggunakan telnet, ssh, menu terminal pada winbox, kabel serial atau secara langsung apabila kita menginstall MikroTik RouterOS pada sebuah PC.

Berikut beberapa perintah dasar mengkonfigurasi MikroTik dengan menggunakan Command Line :

1. Memberi Nama Router




/system identity set name=RouterKu


2. Melihat Interface yang terpasang




/interface print


3. Memberi Nama pada Interface Ethernet




/interface ethernet set ether1 name=Public


/interface Ethernet set ether2 name=Local


atau


/interface set 0 name=Public


/interface set 1 name=Local


atau


/ interface set 0 name=Public; set 1 name=Local


4. Memberi IP Address pada interface Public dan Local




/ip address add address=192.168.67.100/24 interface=Public


/ip address add address=10.10.11.2/24 interface=Local


5.Mengganti IP Address pada Interface Local




/ip address remove 1


/ip address add address=172.16.10.100/24 interface=Local


6. Menambahkan DNS Resolver , Primary DNS dan Secondary DNS




/ip dns static add name=dnsku.com address=172.16.10.100


/ip dns set primary-dns=203.78.115.215 secondary-dns=203.78.115.222 allow-remote-request=yes


7. Menambahkan default gateway




/ ip route add dst-address=0.0.0.0/0 gateway=192.168.67.2 Atau


/ip route add gateway=192.168.67.2


* Misal IP gateway yang digunakan adalah 192.168.67.2


8. Menambahkan NAT Masquerade




/ip firewall nat add chain=srcnat src-address=172.168.10.0/24 out-interface=Public action=masquerade


9.Menambahkan DHCP Server




- Buat IP Pool


/ip pool add name = ippool1 ranges= 172.16.10.1-172.16.10.10






-Setup DHCP Server


/ip dhcp-server add interface=Local address=ippool1






- Setup Netwok; Gateway, DNS Server,..


/ip dhcp-server network add address=172.16.10.0/24 gateway=172.16.10.100 s=dns-server=203.78.115.222


10. Membuat Mark Connection yang nantinya di pakai untuk memilah Paket


/ip firewall mangle add chain=forward src-address=172.16.10.1 action=mark-connection new-connection-mark=billing


/ip firewall mangle add chain=forward src-address=172.16.10.2 action=mark-connection new-connection-mark=pc1


/ip firewall mangle add chain=forward src-address=172.16.10.3 action=mark-connection new-connection-mark=pc2


/ip firewall mangle add chain=forward src-address=172.16.10.4 action=mark-connection new-connection-mark=pc3


11. Membuat mark packet untuk Queue, yang didapat dari mark connection




/ip firewall mangle add chain=forward connection-mark=billing action=mark-packet new-packet-mark=billing


/ip firewall mangle add chain=forward connection-mark=pc1 action=mark-packetnew-packet-mark=pc1


/ip firewall mangle add chain=forward connection-mark=pc2 action=mark-packetnew-packet-mark=pc2


/ip firewall mangle add chain=forward connection-mark=pc3 action=mark-packetnew-packet-mark=pc3


12. Membuat Parent tertinggi Queue




/queue tree add name=E-Net parent=ether2 max-limit=10000000


13. Membuat Queue per terminal




/queue tree add name=pcbil packet-mark=billing parent=E-Net limit-at=64000max-limit=250000


/queue tree add name=pc1 packet-mark=pc1 parent=E-Net limit-at=64000 max-limit=250000


/queue tree add name=pc2 packet-mark=pc2 parent=E-Net limit-at=64000 max-limit=250000


/queue tree add name=pc3 packet-mark=pc3 parent=E-Net limit-at=64000 max-limit=250000


14. Firewall Basic




/ ip firewall filter add chain=forward connection-state=invalid action=drop comment=”drop invalid connections”






add chain=virus protocol=tcp dst-port=135-139 action=drop comment=”Drop Blaster Worm”


add chain=virus protocol=udp dst-port=135-139 action=drop comment=”Drop Messenger Worm”


add chain=virus protocol=tcp dst- port=445 action=drop comment=”Drop Blaster Worm”


add chain=virus protocol=udp dst- port=445 action=drop comment=”Drop Blaster Worm”


add chain=virus protocol=tcp dst- port=593 action=drop comment=”________”


add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=”________”


add chain=virus protocol=tcp dst- port=1080 action=drop comment=”Drop MyDoom”


add chain=virus protocol=tcp dst- port=1214 action=drop comment=”________”


add chain=virus protocol=tcp dst- port=1363 action=drop comment=”ndm requester”


add chain=virus protocol=tcp dst-port=1364 action=drop comment=”ndm server”


add chain=virus protocol=tcp dst- port=1368 action=drop comment=”screen cast”


add chain=virus protocol=tcp dst- port=1373 action=drop comment=”hromgrafx”


add chain=virus protocol=tcp dst- port=1377 action=drop comment=”cichlid”


add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=”Worm”


add chain=virus protocol=tcp dst- port=2745 action=drop comment=”Bagle Virus”


add chain=virus protocol=tcp dst- port=2283 action=drop comment=”Drop Dumaru.Y”


add chain=virus protocol=tcp dst-port=2535 action=drop comment=”Drop Beagle”


add chain=virus protocol=tcp dst- port=2745 action=drop comment=”Drop Beagle.C-K”


add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment=”Drop MyDoom”


add chain=virus protocol=tcp dst-port=3410 action=drop comment=”Drop Backdoor OptixPro”


add chain=virus protocol=tcp dst-port=4444 action=drop comment=”Worm”


add chain=virus protocol=udp dst-port=4444 action=drop comment=”Worm”


add chain=virus protocol=tcp dst-port=5554 action=drop comment=”Drop Sasser”


add chain=virus protocol=tcp dst-port=8866 action=drop comment=”Drop Beagle.B”


add chain=virus protocol=tcp dst-port=9898 action=drop comment=”Drop Dabber.A-B”


add chain=virus protocol=tcp dst-port=10000 action=drop comment=”Drop Dumaru.Y”


add chain=virus protocol=tcp dst-port=10080 action=drop comment=”Drop MyDoom.B”


add chain=virus protocol=tcp dst-port=12345 action=drop comment=”Drop NetBus”


add chain=virus protocol=tcp dst-port=17300 action=drop comment=”Drop Kuang2″


add chain=virus protocol=tcp dst-port=27374 action=drop comment=”Drop SubSeven”


add chain=virus protocol=tcp dst-port=65506 action=drop comment=”Drop PhatBot, Agobot,Gaobot”


add chain=forward action=accept protocol=tcp dst-port=80 comment=”Allow HTTP”


add chain=forward action=accept protocol=tcp dst-port=25 comment=”Allow SMTP”


add chain=forward protocol=tcp comment=”allow TCP”


add chain=forward protocol=icmp comment=”allow ping”


add chain=forward protocol=udp comment=”allow udp”


add chain=forward action=drop comment=”drop everything else”


add chain=input src-address-list=”port scanners” action=drop comment=”dropping portscanners” disabled=no






/ ip firewall filter add chain=virus protocol= udp dst-port=135 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= udp dst-port=137 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= udp dst-port=138 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= udp dst-port=445 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= tcp dst-port=135 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= tcp dst-port=139 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= tcp dst-port=5933 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= tcp dst-port=445 action=drop comment=”Confiker” disabled=no






/ ip firewall filter add chain=virus protocol= tcp dst-port=4691 action=drop comment=”Confiker” disabled=no


15. Set jam Otomatis




system ntp client set primary-ntp=0.pool.ntp.org secondary-ntp=3.pool.ntp.org enabled=yes


16. Membackup System configuration


/system backup save name="Backup-versi1"


17. Restore System configuration




/system backup load name="Backup-versi1"





Demikianlah beberapa contoh MikroTik Command Line Interface untuk mengkonfigurasi MikroTik RouterOS, IP Address yang digunakan pada diatas hanyalah contoh saja, sehingga harus kita ubah sesuai dengan IP Address yang kita kehendaki.

0 komentar:

Post a Comment

http://www.resepkuekeringku.com/2014/11/resep-donat-empuk-ala-dunkin-donut.html http://www.resepkuekeringku.com/2015/03/resep-kue-cubit-coklat-enak-dan-sederhana.html http://www.resepkuekeringku.com/2014/10/resep-donat-kentang-empuk-lembut-dan-enak.html http://www.resepkuekeringku.com/2014/07/resep-es-krim-goreng-coklat-kriuk-mudah-dan-sederhana-dengan-saus-strawberry.html http://www.resepkuekeringku.com/2014/06/resep-kue-es-krim-goreng-enak-dan-mudah.html http://www.resepkuekeringku.com/2014/09/resep-bolu-karamel-panggang-sarang-semut-lembut.html