Cara instalasi Framework Django

 Kali ini ketikanMD akan membuat tutorial yang sesuai dengan judulnya yaitu instalasi Framework django.

1. Pastikan kita sudah menginstall python, untuk mengecek dengan perintah python --version

2. Sekarang kita akan melakukan install PIP, PIP yaitu (PIP Install Packages) / Paket manager pada pemrograman python.

# apt install python3-pip python-dev

3. Melakukan verifikasi instalasi PIP.

$ pip3 -V


4. Selanjutnya kita akan membuat folder  di “~/ketikanMD/” dengan nama “django” untuk menampung project django kita.

5. membuat Env (pastikan sudah berada di dalam folder project) dengan Module yang digunakan untuk membuat Virtual Environments yaitu module venv, kegunaan Virtual environments untuk membuat sebuah environment yang terisolasi dari dunia luar. Sehingga, modul python apapun yang diinstall tidak mempengaruhi environment global, dan yang terpenting, project lainnya. 
$ python -m venv Env
* Terlihat ada folder dengan nama env

6. masuk/mangaktifkan Virtual Environment
$ source env/bin/activate
* Terlihat ada tanda (env) setalah mengeksekusi perintah diatas
7. Melihat package yang sudah diinstall pip.

8. Melakukan upgrade pip
$ pip install --upgrade pip


9. Melakukan instalasi django  disini kita akan install versi 2.2, disini bisa sesuaikan dengan kebutuhan teman".
$ pip install Django==2.2

10. Mengecek instalasi paket django menggunakan pip

11. Sekarang kita akan membuat project django dengan nama project “ketikanMD” dan secara otomatis akan terbuat folder berdasrkan nama project yang sudah ditentukan.

12. Menjalankan project yang kita buat, pastikan kita masuk ke dalam folder project kita yaitu ketikanMD

$ python manage.py runserver


13. Buka browser dan masukkan url http://127.0.0.1:8000 (sesuaikan dengan tampilan tanda kotak merah).



Sekarang kita sudah berhasil menginstall django dan menjalankan project django

14. Untuk Keluar dari environment
$ deactive
* secara otomatis tanda (env) akan hilang

Semoga Berhasil


Source code Aplikasi Mesin ATM Sederhana menggunakan bahasa pemrograman C++

Gimana kabarnya teman teman sekalian...

Hari ini saya akan membagikan source code  aplikasi Mesin ATM sederhana yang dibuat menggunakan bahasa pemrograman C++,dimana aplikasi ini memiliki 4 menu yaitu:

1. Tarik Tunai

2. Tabung Tunai

3. Cek Saldo

4. Transfer

Di dalam aplikasi ini juga diterapkan perulangan do while untuk menanyakan apakah akan melakukan transaksi kembali setelah transaksi sebelumnya berhasil...

Berikut saya lampir kan source code nya:

#include <iostream>
#include <cstdlib>

using namespace std;
int saldo_awal;

void header(){
cout<<"=========================================\n"
	<<"\t	SELAMAT DATANG DI ATM BERKAH		\n"
	<<"========================================= \n";
}
void footer(){
cout<<"=========================================\n"
	<<"\t	Terima Kasih atas kunjungan anda\n"
	<<"\t silahkan cek kembali uang anda\n"
	<<"dan pastikan tidak ada barang yang tertinggal\n"
	<<"========================================= \n";
}

void cekSaldo(){
    	cout<<"total saldo anda sekarang adalah "<<saldo_awal <<" rupiah"<< endl;
	cout<<"=========================\n";
}

int main(){
	
int tarik,setor,rekTujuan,transfer,kode;
string ulang;

header();
                    
cout<<"silahkan masukkan Saldo Awal anda:";
cin>>saldo_awal;

menu :
	cout<<"\nselamat datang\n\n";
	do{
	 system ("cls");
cout<<"PILIHAN MENU\n";
cout<<"1.tarik tunai\n2,tabung tunai\n3,cek saldo\n4,transfer\n\n";
cout<<"Masukkan kode menu :";
cin>>kode;
if(kode == 1){
	tarik :
cout<<"\n==========================\n";
cout<<"tarik tunai\n";
cout<<"============================\n";
cout<<"silahkan masukkan uang yang anda ingin ambil:";
cin>>tarik;
if(tarik<0){
cout<<"Jumlah penarikan masih kosong\n";
system("cls");
header();
goto tarik;
}
else{
	if (tarik>saldo_awal){
		cout<<"saldo tidak mencukupi\n";
	}
else{
	saldo_awal-=tarik;
	cout<<"=========================\n";
	cout<<"silahkan hitung kembali uang yang telah anda ambil\n";
	cekSaldo();
}
system("cls");
}
}else if (kode==2){
	setor :
cout<<"\n==========================\n";
cout<<"setor tunai\n";
cout<<"============================\n";
cout<<"silahkan masukkan uang yang anda ingin setor:";
cin>>setor;
if(setor<0){
cout<<"Jumlah setor masih kosong\n";
system("cls");
header();
goto setor;
}else{
	saldo_awal+=setor;
	cout<<"=========================\n";
	cout<<"silahkan hitung kembali uang yang telah anda ambil\n";
	cekSaldo();
}
}else if (kode==3){
	cout<<"\n=======================\n";
	cout<<"cek saldo\n";
	cout<<"=========================\n";
	cekSaldo();
system("cls");

}else if (kode==4){
	transfer :
cout<<"\n==========================\n";
cout<<"transfer\n";
	cout<<"=========================\n";
 cout << "Masukkan No. Rekening Tujuan: ";
      cin >> rekTujuan;
cout<<"============================\n";
cout<<"silahkan masukkan jumlah uang yang anda ingin transfer:";
cin>>transfer;
if(transfer<0){
cout<<"Jumlah transfer masih kosong\n";
system("cls");
header();
goto transfer;
}
else{
	if (transfer>saldo_awal){
		cout<<"saldo tidak mencukupi\n";
	}
else{
	saldo_awal-=transfer;
	cout<<"=========================\n";
	cout << " Anda telah transfer ke " << rekTujuan << " sebesar " << transfer <<
	" Rupiah"<< endl;
cekSaldo();
}
system("cls");
}
}else{
	cout<<"\nkode yang anda masukkan tidak ada,\npastikan kode yang anda masukkan benar\n";
system("pause");
system("cls");
header();
goto menu;
}
  cout << "Anda ingin melakukan transaksi lainnya ? <y/n> ";
      cin >> ulang;
      if (ulang == "y")
	{
	  system ("cls");
	}
      else if (ulang == "n")
	{
	  system ("cls");
	  cout <<
	    "Terima Kasih telah menggunakan ATM BERKAH\n Semoga hari anda menyenangkan ";
	}
}  while (ulang == "y");
}


Gambar Hasil menjalankan program


Saya berharap semoga melalui tulisan ini dapat membantu teman teman sekalian..

Menjalankan golang di Docker

Sekarang kita akan membahas bagaimana cara menjalankan file golang menggunakan docker, tanpa basa basi kita mulai:

1.Membuat folder sebagai contoh disini kita akan membuat foder dengan nama “belajar-golang” di dalam folder ~/Document/ untuk menampung file go dan Dockerfile. Setelah itu Masuk ke dalam folder  belajar-golang

2.Membuat file Dockerfile di folder belajar-golang yang didalamnya berisi script berikut.

FROM golang:latest

RUN mkdir /app

WORKDIR /app


3. Menjalankan dockerfile dengan membuat image baru sebagai contoh “go-simple” dengan perintah

- docker build -t go-simple .

4. Mengecek images “go-simple” yang telah dibuat dengan perintah

- docker images

5. Membuat container menggunakan image id “go-simple” dengan nama container “golang”.

- docker run -td -v ~/Documents/belajar-golang:/app --name golang 17f5d90daf3c

6. Mengecek container apakah sudah berjalan  dan pastikan status dalam keadaan up.

7. Sekarang kita akan membuat file main.go dengan isian code sebagai berikut

package main
import "fmt"
func main() {
   nama := "KetikanMd"
   fmt.Println(nama)
}

8. Pastikan file main.go dan dockerfile didalam folder yang sama.

9. Sekarang kita akan menjalankan file go ada di dalam container yang sudah syncron dengan file yang ada di local laptop kita.

- docker exec golang go run main.go

* maka output yang dikeluarkan yaitu ketikanMD sesuai output yang diinginkan pada file main.go

Semoga berhasil....





Cara mengetahui IP parangkat dalam satu jaringan

Kali ini ketikanmd akan menulis artikel berkaitan dengan pengalaman pribadi sipenulis, kasusnya saya sama rekan kerja sedang melakukan maintenance jaringan salah satu kendala yang kami hadapi yaitu kebingungan untuk mengatahui ip address perangkat access point hal ini dikarenakan yang melakukan settingan perangkat AP nya karyawan sebelumnya. setelah mencari beberapa cara kami mendapatkan satu cara yang dibilang cara terakhir yaitu menggunakan script setelah menemukan beberapa ip yang statusnya success maka kami coba satu" untuk mengetahui ip perangkat yang kami cari alhasil kami berhasil, tidak perlu banyak cerita langsung saja ke tutorialnya:

Note: disini menggunakan sistem operasi windows.

  1.  pertama buka powershell, dengan cara ketik powershell di pencarian windows

  2. Copykan script berikut ke powershell

Penjelasan:

-simpan perintah ping ke dalam variable $ping

$ping = New-Object System.Net.Networkinformation.Ping

1..254 | % { $ping.send(“192.168.7._$”) | select address, status}

  • 1..254 -> range ip yang akan diping

  • 192.168.7. -> network ip yang akan di ping.


Sesuaikan dengan case yang dilapangan, Semoga bermamfaat walaupun ini bukan cara yang terbaik tapi tidak menutup kemungkinan kita akan membutuhkan.



Mengerjakan challenge SOAL dengan menggunakan bahasa pemrograman C++

Hari ini saya akan mengerjakan sebuah soal dengan menggunakan bahasa pemrograman C++. Adapun soal yang akan saya kerjakan adalah sebagai berikut:

25 / 100

Keterangan:

- dibutuhkan 25 hari untuk membangun sebuah kebiasaan
- dibutuhkan 100 hari untuk membangun sebuah gaya hidup

Berdasarkan rumus di atas, seorang lelaki sebut saja si Aldi bertekad membuat kegiatan lari pagi sebagai gaya hidupnya. Jika lari pagi sudah tercatat sebagai kebiasaannya sejak Minggu, 1 Januari 2021 maka pada hari dan tanggal berapakah dia mulai lari pagi dan lari pagi menjadi gaya hidupnya? 

Ketentuan:

1. Tiap bulan memiliki 30 hari, tiap tahun memiliki 12 bulan.

2. Menggunakan maksimal 7 variabel. 

3. Terdapat 4 input-an untuk hari, tanggal, bulan dan tahun. 

4. Minimal terdapat dua penggunaan switch-case.

5. Terdapat penggunaan statement looping.


Berikut saya tampilkan source code nya:

#include <iostream>

using namespace std;

string KonversiHari (int inputHari){
  switch (inputHari){
    case 0:
      return "Minggu";
      break;
    case 1:
      return "Senin";
      break;
    case 2:
      return "Selasa";
      break;
    case 3:
      return "Rabu";
      break;
    case 4:
      return "Kamis";
      break;
    case 5:
      return "Jumat";
      break;
    case 6:
      return "Sabtu";
      break;
    default:
      return "Hari salah";
    }


}

string KonversiBulan (int inputBulan){
  switch (inputBulan){
    case 1:
      return "Januari";
      break;
    case 2:
      return "Februari";
      break;
    case 3:
      return "Maret";
      break;
    case 4:
      return "April";
      break;
    case 5:
      return "Mei";
      break;
    case 6:
      return "Juni";
      break;
    case 7:
      return "Juli";
      break;
    case 8:
      return "Agustus";
      break;
    case 9:
      return "September";
      break;
    case 10:
      return "Oktober";
      break;
    case 11:
      return "November";
      break;
    case 12:
      return "Desember";
      break;
    default:
      return "Bulan salah";
    }


}

int CekHari (int hari, int hitungan){
  if (hari == 0){
      if (((hitungan + hari) % 7) == 0){
	  return hari;
      }else{
	  return 7 - ((hitungan + hari) % 7);
      }
      return hari;
    }else
     return hari - (hitungan % 7);
}


void CekKebiasaan (string keterangan, int hari, int hitungan,
	      int inputTanggal, int inputBulan, int inputTahun, bool mulai){
  int tanggal = inputTanggal;
  int bulan = inputBulan;
  int tahun = inputTahun;
  if (mulai)
    {
      for (int i = hitungan; i >= 1; i--)
	{
	  tanggal--;
	  if (tanggal < 1)
	    {

	      tanggal = 30;
	      bulan--;
	      if (bulan < 1)
		{
		  bulan = 12;
		  tahun--;
		}
	    }

	}
    }
  else
    {

      for (int i = 1; i <= hitungan; i++)
	{

	  tanggal++;
	  if (tanggal > 30)
	    {
	      tanggal = 1;
	      bulan++;
	      if (bulan > 12)
		{

		  bulan = 1;
		  tahun++;
		}
	    }
	}

    }

  cout << keterangan <<
    KonversiHari (mulai ? CekHari (hari, hitungan)
		  : ((hitungan +
		      hari) %
		     7)) << ", " << tanggal << " " <<
    KonversiBulan (bulan) << " " << tahun;
}



int main (){
  int inputHari, inputTanggal, inputBulan, inputTahun;
  cout << "Masukkan hari (0 = Minggu..... 6 = Sabtu)" << endl;
  cout << "Pilihan Anda: ";
  cin >> inputHari;
  cout << "\nMasukkan tanggal: ";
  cin >> inputTanggal;
  cout << "\nMasukkan bulan: ";
  cin >> inputBulan;
  cout << "\nMasukkan tahun: ";
  cin >> inputTahun;
  CekKebiasaan ("\nAldi mulai pada hari ", inputHari, 25,
		inputTanggal, inputBulan, inputTahun, true);
  cout << "\nMenjadi kebiasaan pada hari " <<
    KonversiHari (inputHari) << ", " << inputTanggal << " " <<
    KonversiBulan (inputBulan) << " " << inputTahun;
  CekKebiasaan ("\nMenjadi gaya hidup pada hari ", inputHari, 75,
		inputTanggal, inputBulan, inputTahun, false);
  return 0;
}








Script mengaktifkan user hotspot sesuai jadwal harian pada mikrotik

Ketemu lagi niiiii, penulis akan membagikan tutorial dan script yang digunakan berdasarkan pengalaman pribadi si penulis kasusnya si pelanggan punya beberapa user hotspot sedangkan si pelanggan pengen setiap user bisa dipakai berdasarkan hari tertentu akhirnya setelah otak atik dan mencari tutorial di berbagai sumber akhirnya penulis menemukan script yang work it, langsung saja ke tutorial.

Hal pertama Pastikan pengaturan waktu pada router mikrotik sudah sesuai dengan waktu wilayah anda hal ini mutlak diperlukan ketika anda sudah implementasikan rule-rule berdasarkan waktu misalnya dalam case ini penggunaan scheduler

Pengaturan waktu pada router mikrotik memiliki alternatif lain yaitu menggunakan service NTP (Network Time Protocol) yang memungkinkan router bisa melakukan sinkronisasi waktu, untuk case ini router kita akan jadikan NTP Client, pengaturan sntp client pada router mikrotik bisa dilakukan pada menu System > SNTP Client.

SNTP Client

Setelah pengaturan sntp selesai dan waktu router mikrotik sudah sesuai sekarang kita akan membuat scheduler untuk menambahkan script.
Untuk penjadwalan kita bisa konfigurasi pada menu System > Scheduler lalu klik icon "+"  untuk membuat schedule baru. Berikut nama misalnya "Aktif User", waktu eksekusi script setiap jam 1 malam dan interval waktu setiap 1 hari, untuk kolom On Event masukkan script yang sudah disediakan dibawah.

Selanjutnya kita buatkan user hotspot di menu Ip > Hotspot, pada halaman hotspot pilih tab users  lalu klik icon "+"  untuk membuat User baru dan jangan lupa untuk menambahkan comment pada masing" user hal ini dikarenakan sebagai kunci pada script untuk melakukan disable atau enable user seperti pada gambar dibawah.

Untuk melakukan mengujian sesuaikan dengan waktu yang sudah disetting pada kolom Start Time.


Berikut penulis sertakan Script nya





:local date [/system clock get date]

# Math Calculation here
:local result ""
:local months [:toarray "jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec"]
:local daytbl [:toarray "sun,mon,tue,wed,thu,fri,sat"]

:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
:local year [:pick $date 7 11]

# if the first char is a 0 (zero) only read last char, else script fails
:if ([:pick $date 4 5] = 0) do={ :set day ($dayc)}

:local sum 0
:local aaa 0
:local yyy 0
:local mmm 0
:local nmonth 1

:for mindex from=0 to=[:len $months] do={
  :if ([:pick $months $mindex] = $month) do={:set nmonth ($mindex + 1) }
}

:set aaa ((14 - $nmonth) / 12)
:set yyy ($year - $aaa)
:set mmm ($nmonth + 12 * $aaa - 2)
:set sum (7000 + $day + $yyy + ($yyy / 4) - ($yyy / 100) + ($yyy / 400) + ((31 * $mmm) / 12))
:set sum ($sum - (($sum / 7) * 7))
:set result [:pick $daytbl $sum]

:if ($result = "mon") do={/ip hotspot user set disable=no [find comment=Senin]} else= {/ip hotspot user set disable=yes [find comment=Senin]}
:if ($result = "tue") do={/ip hotspot user set disable=no [find comment=Selasa]} else= {/ip hotspot user set disable=yes [find comment=Selasa]}
:if ($result = "wed") do={/ip hotspot user set disable=no [find comment=Rabu]} else= {/ip hotspot user set disable=yes [find comment=Rabu]}
:if ($result = "thu") do={/ip hotspot user set disable=no [find comment=Kamis]} else= {/ip hotspot user set disable=yes [find comment=Kamis]}
:if ($result = "fri") do={/ip hotspot user set disable=no [find comment=Jumat]} else= {/ip hotspot user set disable=yes [find comment=Jumat]}
:if ($result = "sat") do={/ip hotspot user set disable=no [find comment=Sabtu]} else= {/ip hotspot user set disable=yes [find comment=Sabtu]}
:if ($result = "sun") do={/ip hotspot user set disable=no [find comment=Ahad]} else= {/ip hotspot user set disable=yes [find comment=Ahad]}

Trik Menampilkan Postingan terbaru Instagram ke website Tanpa menggunakan API

 Kita bertemu lagi niiiiiiii….kali ini kita akan belajar bagaimana cara mengambil postingan terbaru instagram dari akun orang lain yang akan kita masukkan ke dalam website/blog kita …untuk mendapatkan postingan orang lain sebenarnya banyak cara yang bisa kita gunakan…terus apa yang akan kita gunakan?nah kali ini kita akan menggunakan AJAX.

Langsung saja ke TKP

*Note: Pastikan akun dari postingan yang akan kita ambil bersifat public

Berikut saya sertakan Source Code nya, 

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
<!DOCTYPE html>
<html>
<style type="text/css">
	.center {
  margin: auto;
  width: 50%;
  height: 50%;
  padding: 10px;
}
</style>
<head>
	<title>KetikanMD</title>
	<!-- jquery untuk menjalankan ajax -->
	<script src="https://code.jquery.com/jquery-3.5.1.min.js" integrity="sha256-9/aliU8dGd2tb6OSsuzixeV4y/faTqgFtohetphbbj0=" crossorigin="anonymous"></script>

	<!-- Sertakan skrip ini dalam HMTL Anda: -->
	<script async src="https://www.instagram.com/embed.js"></script>
</head>
<body>
<div id="instagram" class="center"></div>
</body>
<script>
    $(document).ready(function() {
    	// Username postingan Instagram
    	var username="ahmad22_97";
        $.ajax({
            url: "https://www.instagram.com/"+username+"/?__a=1",
            type: 'GET',
            success: function(data) {
                var getData = data.graphql.user.edge_owner_to_timeline_media.edges[0].node.shortcode;
                // Start Code embed Instagram
                $("#instagram").html(
                    `
<blockquote class="instagram-media" data-instgrm-permalink="https://www.instagram.com/p/${getData}/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
    <div style="padding:16px;"> <a id="href1" href="https://www.instagram.com/p/${getData}/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank">
            <div style=" display: flex; flex-direction: row; align-items: center;">
                <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
                <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
                    <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
                    <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
                </div>
            </div>
            <div style="padding: 19% 0;"></div>
            <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink">
                    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
                        <g transform="translate(-511.000000, -20.000000)" fill="#000000">
                            <g>
                                <path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path>
                            </g>
                        </g>
                    </g>
                </svg></div>
            <div style="padding-top: 8px;">
                <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> Lihat postingan ini di Instagram</div>
            </div>
            <div style="padding: 12.5% 0;"></div>
            <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
                <div>
                    <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
                    <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
                    <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
                </div>
                <div style="margin-left: 8px;">
                    <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
                    <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
                </div>
                <div style="margin-left: auto;">
                    <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
                    <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
                    <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
                </div>
            </div>
            <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
                <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
                <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
            </div>
        </a>
        <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a id="href2" href="https://www.instagram.com/p/${getData}/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">Sebuah kiriman dibagikan oleh BP2MI UPT Wilayah Mataram (@bp2mi.mataram)</a> pada <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-07-19T23:02:22+00:00">19 Jul 2020 jam 4:02 PDT</time></p>
    </div>
</blockquote>
                            `);
// End Code embed Instagram

// mencari embed Instagram dan memuatnya
                if (typeof window.instgrm !== 'undefined') {
                    window.instgrm.Embeds.process();
                }
            }
        });

    });
</script>

</html>


Berikut cara mendapatkan code embed postingan instagram:
Buka Profil akun instagram yang akan kita ambil postingannya dan pilih postingan yang akan dijadikan embed .
Klik simbol titik tiga (...) yang ada di pojok kanan post. Pada Saat muncul tampilan pop-up,

klik Sematkan atau dalam bahasa inggrisnya Embed.

Klik tombol "Salin Kode Sematan" atau dalam bahasa inggrisnya "Copy Embed Code" untuk mengambil kode yang akan dijadikan embed.

setelah Embed Code berhasil didapat  silahkan ganti code yang terdapat pada baris 34-80 dengan Embed Code instagram kalian sendiri.

Pada pilihan bagian "Sertakan Keterangan" atau bahasa inggrinsya "Include caption"  Kita bisa uncheck jika tidak ingin menampilkan bersama keterangan/caption dari postingannya.

Berikut Output code yang dihasilkan….untuk selanjutnya teman-teman silahkan mengembangkan sesuai keperluan.....



Jika ada pertanyaan atau kendala saat mengukuti tutorial ini,silahkan tinggalkan pertanyaan teman teman dibawah